Solaris 10 : Unique Instance Error Pkgadd

Untuk menginstal paket di Solaris 10, saya biasanya menggunakan perintah pkgadd. Misalnya saya punya paket Wireshark yang saya dapat dari Internet. Untuk menginstalnya saya gunakan perintah seperti berikut ini :

root@testbed:/tmp# pkgadd -d wireshark-1.6.8-sol10-sparc-local 

The following packages are available:
  1  SMCwires     wireshark
                  (sparc) 1.6.8

Select package(s) you wish to process (or 'all' to process
all packages). (default: all) [?,??,q]: 1

Processing package instance <SMCwires> from </tmp/wireshark-1.6.8-sol10-sparc-local>

wireshark(sparc) 1.6.8

Current administration requires that a unique instance of the
<SMCwires> package be created.  However, the maximum number of
instances of the package which may be supported at one time on the
same system has already been met.

No changes were made to the system.
root@testbed:/tmp# 

Ternyata muncul error seperti di atas, pkgadd menolak untuk menginstal Wireshark versi 1.6.8 karena sudah ada Wireshark versi lain. “Current administration requires that a unique instance”, itu tandanya saya perlu membuang dulu Wireshark versi lamanya. Membuang paket (uninstall) di Solaris 10, saya perlu menggunakan perintah pkgrm seperti contoh di bawah ini :

root@testbed:/tmp# pkgrm SMCwires

The following package is currently installed:
   SMCwires  wireshark
             (sparc) 1.6.4

Do you want to remove this package? [y,n,?,q] y

## Removing installed package instance <SMCwires>
## Verifying package <SMCwires> dependencies in global zone
## Processing package information.
## Removing pathnames in class <none>
/usr/local/share/wireshark/ws.css
/usr/local/share/wireshark/wireshark.html
/usr/local/share/wireshark/wireshark-filter.html
/usr/local/share/wireshark/wimaxasncp/dictionary.xml
/usr/local/share/wireshark/wimaxasncp/dictionary.dtd
/usr/local/share/wireshark/wimaxasncp
...
...
...
/usr/local/bin/wireshark
/usr/local/bin/tshark
/usr/local/bin/text2pcap
/usr/local/bin/rawshark
/usr/local/bin/randpkt
/usr/local/bin/mergecap
/usr/local/bin/idl2wrs
/usr/local/bin/editcap
/usr/local/bin/dumpcap
/usr/local/bin/dftest
/usr/local/bin/capinfos
/usr/local/bin <shared pathname not removed>
## Updating system information.

Removal of <SMCwires> was successful.
root@testbed:/tmp# 

Setelah Wireshark versi 1.6.4 tadi sukses di-uninstall, barulah Solaris mengijinkan saya menginstal Wireshark versi 1.6.8.

root@testbed:/tmp# pkgadd -d wireshark-1.6.8-sol10-sparc-local 
The following packages are available:
  1  SMCwires     wireshark
                  (sparc) 1.6.8

Select package(s) you wish to process (or 'all' to process
all packages). (default: all) [?,??,q]: 1

Processing package instance <SMCwires> from </tmp/wireshark-1.6.8-sol10-sparc-local>

wireshark(sparc) 1.6.8
Gerald Combs et al
Using </usr/local> as the package base directory.
## Processing package information.
## Processing system information.
   7 package pathnames are already properly installed.
## Verifying disk space requirements.
## Checking for conflicts with packages already installed.
## Checking for setuid/setgid programs.

Installing wireshark as <SMCwires>

## Installing part 1 of 1.
/usr/local/bin/capinfos
/usr/local/bin/dftest
/usr/local/bin/dumpcap
/usr/local/bin/editcap
/usr/local/bin/idl2wrs
/usr/local/bin/mergecap
/usr/local/bin/randpkt
/usr/local/bin/rawshark
/usr/local/bin/text2pcap
/usr/local/bin/tshark
/usr/local/bin/wireshark
...
...
...
/usr/local/share/wireshark/tshark.html
/usr/local/share/wireshark/wimaxasncp/dictionary.dtd
/usr/local/share/wireshark/wimaxasncp/dictionary.xml
/usr/local/share/wireshark/wireshark-filter.html
/usr/local/share/wireshark/wireshark.html
/usr/local/share/wireshark/ws.css
[ verifying class <none> ]

Installation of <SMCwires> was successful.
root@testbed:/tmp# 

Leave a Reply